Follow

Open with Windows Explorer slow performance

When I choose to 'Open with Windows Explorer' it takes up to 15 seconds to open Windows Explorer.

Problem:

When accessing a SharePoint/WorkPoint document library your Windows Explorer uses the WebDAV technology. This technology is affected by different settings. Some of these settings may have been set incorrect.

Solution 1 :

  1. In HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > WebClient > Parameters, add a new Multi-String Value named "AuthForwardServerList".
  2. In the Value data field, add one URL you visit, following by the SharePoint server FQDN on the next line.  Repeat for each URL you are having long wait times for.  In the end, you'll have something like:

https://*.yourdomain.com
sharepointservername.yourdomain.com
https://otherspsite.yourdomain.com
otherspservername.yourdomain.com

The idea behind this is to explicitly tell WebDAV where to first go for authentication.  This cleared up the majority of access speed issues with SP and we were back to sub-second access.

 

Solution 2:

You man experience that access would degrade for some reason for certain users. Turns out to be MS updates that make changes to IE settings. 

  1. Go to IE Options > Advanced Settings tab and hit RESET.  Whatever RESET does fixed the speed issues with Explorer View.

When I choose to 'Open with Windows Explorer' it takes up to 15 seconds to open Windows Explorer

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments